2009年01月19日

危機の克服?

 土曜日の「寝言」で不適切な表現がありましたので、訂正いたします。デルのC521を「セカンドマシーンとしてすら、不適格です」とまで書きましたが、やはり優秀でした。これで、USB関連のトラブルさえなければと思います。迂闊にも、日曜日まで勘違いしていたのですが、光学ドライブもSATA接続で、これが大活躍しました(ただ、読み込みの際の爆音は心臓に悪いのですが)。あとは、コメントでご指摘頂いた"memtest"を今まで知らなかったというのは恥ずかしい限りです。メモリー増設が直接のきっかけだったので、素直にメモリーの問題から考えればよかったのですが、最初は狼狽し、次にあれこれ考えすぎて、肝心なことを忘れておりました。現在、Windows Home editionを再インストールして、memtest86+でチェックが終わり、正常に起動できる状態になりました。

 結果からすると、現時点で判明した異常は、(1)Windowsの起動領域になんらかの異常があり、私の貧しい知識では回復コンソールでは解決できず、再インストール以外に解決できなかったこと、(2)メモリーもしくはスロットのいずれか、もしくは双方に異常があり、POSTで停止が生じていたこと、という2点です。「ASUS EZ Flash2」が相変わらず、すべてのディスクを表示するので、単に仕様が変わっただけかもしれませんが、微妙に気もち悪いのですが。以前のバージョンでは、USBメモリーを挿入しておくと、CD-ROMドライブとして認識していたのですが、Cドライブはドライブ名が空白なのですが、それ以外のドライブは意味不明の記号が並んで、光学ドライブは正常に製品名が表示されます。とりあえず、早急にマザーボードを変えるところまではゆかなかったので、様子を見ながらよさげなマザーを買おうかなと。再度、テストをかけてからになりますが、メモリスロットの異常の可能性が高いので、買い替えも考えておいた方がよい状態です。

 それにしても、今回の「危機」のおかげで、しみじみ凡庸な人間だなと感じますね。「危機」のきっかけがメモリー増設だったので、増設した部分を外して作業していたのですが、増設したスロットには異常がなく、既に使っていたスロット、もしくはスロットで使用していたメモリに異常が生じていたことに気がつきませんでした。思い込みがよくないのは当たり前なのですが、これまで正常な動作してきたスロットの方に異常があるというのは、完全に盲点になっていました。ありがちなことではありますが、増設してから異常が生じたので、増設したスロット、もしくはメモリーに異常があると思い込んでしまったことが、危機を長引かせてしまいました。

 もう一つは、狼狽と焦りです。これも平凡な話ですが、昨年、苦労したものの、とくに初期不良もなく、立ち上がったせいで、この種のトラブルに不慣れでした。まあ、凡人なので、トラブルで狼狽するのはしょうがないよねと慰めるしかないのですが、こういうときはやはり冷静になるのが肝心だなあと。「ヤバイ」と思ったら、深呼吸して対応するゆとりがありませんでした。これが焦りと混じると、もう意味のないことを繰り返して、疲れるだけです。自己評価よりも幼稚だなと思いました。今となっては、先週からの作業は無駄なことばかりでした。性懲りもなく、同じことを繰り返すのかもしれません。他方で、年を食ってくると、無理がきかなくなり、なんとなく「まあ、こんなもんだろう」という気分になることも増えてくるので、それを老化と呼ぶのか、成熟と呼ぶのかは主観に属する問題でしょうが、私みたいな凡人からすると、歴史に学ぶどころか、経験から学ぶことができれば、やはり優秀な方なのでしょう。

 末尾になりましたが、適切かつ有益なコメントを頂いたやすゆき様にお礼を申し上げます。


 日曜は午前から用があったため、結局、徹夜になってしまった。帰ってきてから思いついたのは、C521のHDDがSATA接続なので、自作機からHDDを取り外してC521の内蔵ドライブと交換するということだった。早速、試みた。

 C521の内部を見るたびに感心するのだが、メーカー製だから当然ではあるが、ケーブル類がすっきり整理されていて、スリムタワーだけにエアフローが苦しいだろうが、見たところ、実にわかりやすい。それと自作機を比較すると、初めてということもあるが、電源ケーブルをバンドルしても、なんとも見苦しい。ミドルタワーで前面に2つのファン、上部と背部に各1箇所ずつファンがあるので、冷却性能が当然ながら、比較にはならないのだが。

 ドライバーを用意してC521の解体作業に入ったのだが、全くドライバーは不要だった。簡単な操作で、光学ディスク、FDDが外せる。問題はHDDでケースからの外し方がわからないので、乱暴だがSATAケーブルと電源ケーブルを抜いた。最悪の場合、2台とも故障してしまうが、なにもしないよりもマシだ。自作機から外したHDDを接続してケースカバーを開けたまま、作業にとりかかる。

 まず、通常に立ち上げようとすると、Windowsの起動画面が出現した。しかし、それは一瞬で、ブルーバックスクリーンが一瞬、出現してすぐに再起動した。要は、ログオン画面に移行しない。エラー内容を確認しなかったのはミスだったが、これで"Boot.ini"が破損している可能性はほとんどなくなった。

 次に、回復コンソールで、"kernel32.dll"の回復を実施した。手順はマイクロソフトが公表している(参照)。しかし、やはりOSを起動させてもブルーバックスクリーンが出現するので、もはや再インストールしかなく、SP3統合済みDVDを使用せずに、元のCD-ROMからSP2をインストールすることにした。統合ソフトを使えていないせいか、以前、使用したときに、エラーが多発したというだけのことだが。ちなみに業務用のソフトでライセンス認証に厳しいソフトのサポートに問い合わせたところ、以前よりも対応が柔軟になっていて、再インストールに関しては再度、認証を行えば済むようだ。以前は、ライセンスを追加させられた知人がいたため、やや神経質になりすぎていたようだ(やはり10万円近い出費になるので貧乏人にはつらい)。

 C521を分解して初めて気がついたのだが、パラレルケーブルはFDDのものだけで、光学ディスクもHDDと同じくSATA接続だった。ドライブ自体は今ひとつで、とくに読み込み時に壊れるのではないかと心配になるぐらい音が大きいのだが、データの転送は速い。セットアップ画面まで達して、念のためフォーマットをかけてから再インストールしたが、20分もかからず、少し驚いた。320GBのHDDをパーティションで80GBと240GBに分けている。80GB部分のフォーマットと再インストールが終わると、無事に再起動。ただし、BIOSが影響しないとは思うが、USB関係でトラブルが生じる可能性があるので、電源を落としてから、インストールに使ったマウスを自作機に直結した。その後、C521へ各種ディスクを組み込んで、起動させると、正常に動作したので、ホッとした。早速、モニターをもう1台準備して、自作機には15型のモニターをRGB接続で監視する。C521は、19型モニターで、こちらがいつも使っている方だ。不都合が生じたときには、C521で検索を行うため。

 事前に、自作機は、一度、CPU以外のパーツをすべて外して、マザーボードを取り出して、メモリーも取り外して、再度、はめ込んだ。再度、組み立て作業を行い、HDDを1台だけ取り外した上体でOSの再インストールを行った。C521で再インストールを終えたHDDを組み込んでSATAのケーブルと電源の接続を慎重に行った。電源ケーブルがトラブル前よりごたごたしているが、トラブルが収まるまではどこを外すかもしれず、当座は干渉さえしなければよい。組み立てが終わって起動させると、驚いたことに、作業前と同じ状態だ。土曜日に回復コンソールを試す際に、HDDのSATA接続を1台に限定し、試しにOSを入れていないほうだけを接続してインストールを試みたが、どうにもならなかった。Windowsの起動画面からログオン画面に移行せず、起動画面が表示された後にタイムアウト。疲労がどっと出た。すべては無駄だったのか。

 万策尽きたので、ベットで横になり、眠ってしまった。1時間ぐらいで目が覚めたが、意外とぐっすりと眠れたようで、開き直って、HDDは正常なはずだから(ひょっとしたら自作機で起動した際に起動領域に異常が生じたという懸念はあったが)、マザーボード自体を含めて他のパーツの異常を確認しようと、C521で検索。といっても、「価格.com」のP5Q-Eの口コミ情報を見た程度だが。そこで、私と同じ初心者らしき人がBIOS画面が表示されないというので質問をしていて、手馴れた人と思しき方がとりあえず、"memtest"をかけろと罵倒していた。表現は厳しいがダウンロードから使い方を丁寧に説明したサイトへのリンクまで貼ってあり、自作機愛好家は殺伐とした表現ながらも、親切な人が多いと感心する。「時の最果て」でも、貴重なコメントを賜り、とても心強い。早速、フロッピーディスクに落として、午後8時ぐらいからテストを開始する。ちと面倒なのは対象となるメモリーがすべて同じ型番で1GBのものが4枚あることだ。これを1枚ずつテストする必要がある。

 もう一つの問題は、メモリスロットだ。BIOS設定画面で"Quick Boot"をオフにすると、メモリーのチェックでストップすることが頻発する。問題は、POSTの段階ではどのスロットのメモリーに異常が生じているのかがわからないことだ。P5Q-EではDDR2をサポートしており、メモリスロットはA1、A2、B1、B2の順で並んでいる。スロットA1とB1が黄色、スロットA2とB2は黒で同色に挿されたメモリーがデュアルチャネルで動作する。あらためてメモリーを差し込んだときに、違和感があったのが、昨年、組み立てた際に使っていたA1だった。メモリーを押し込むときに、どのスロットでも、やや強い力がいるが、パチンと両サイドのピンが閉じない。まず、A1を検査しようとすると、驚いたことに"memtest86+"がエラーすら吐き出さずに、途中で止まってしまう。詳細を説明しているサイトでは、メモリーに異常がある場合、エラーが表示されて検査が続くとあったが、エラー表示さえなく、検査がストップした。ちょっと唖然とするが、再起動すると、POSTでメモリーのチェックで止まる。このスロットとA1で使用していたメモリーに異常がある可能性が高くなった。以上の結果から、他のスロットにおける他のメモリーの検査することを優先することにした。

 他のスロットに挿入していたメモリーを記憶して、同じスロットで検査を行った。順番は、B1→A2→B2である。他のサイトも覗いてみると、最低でも4回、10回程度検査をしてエラーが発生しなければ(検査内容は同じで、それを繰り返すということ)、正常に動作していると見てよいようだ。検査を開始すると、1回の検査で約13分弱かかるので、時間がかかりすぎる。2回に留めて、OSを起動できるかどうか試すことにする。1枚のメモリーのチェックが終わると、差し替える作業があるので、大体、1枚につき30分程度。1時間30分だ。B1のチェックはとくに問題なく、エラーはなかった。ついで、A2、B2の各スロットで増設したメモリーを検査したが、やはりエラーが生じない。2回の繰り返し検査ではあてにならないかもしれないが、少なくとも増設したメモリーにトラブルがある確率は低そうだ。問題は、A1のスロットとメモリーだ。その前に、正常に検査を行った際に、ちょっと気になる表示があった。表示の一部だが、システムバスとメモリーの転送速度が低い。なお、メモリー自体はDDR2として正常に認識されていた。まあ、CPU-Zでも当初は低い値だったので、気にするほどではないのかもしれないが。なお、メモリーのレイテンシやタイミングなどをBIOS設定でオーバークロックのタブで設定しないと、5−5−5−15だが、4−4−4−12で設定してあるので、多少はオーバークロック耐性のテストになっているのかもしれない(本当か?)。

FSB:334MHz RAM:400MHz(DDR801)

 A1のスロットに挿入したメモリーの問題は、スロット自体に問題があるのか、メモリーが接触不良などを起こすように破損しているのか区別できないことだ。POSTのプロセスでBIOSがストップすることは、素人の浅知恵だが、メモリーに接触不良が生じているのかもしれない。その場合、次の問題がある。(1)スロットの接触部分が破損しており、他のメモリーを差し込んだ場合、そのメモリーが破損してしまう危険がある。(2)メモリーの接触部分が破損しており、そのメモリーを他のスロットに差し込んだ場合、スロットの接触部分を傷めてしまう危険がある。少し躊躇うが、現時点でA2とB2はデュアルチャネルで動くので、この2つのスロットと増設用メモリーが傷まなければ、最低でも2GBは確保できる。したがって、A1で動作していたメモリーをB1でテストし、B1で動作していたメモリーをA1でテストすれば、最悪の場合、両方のメモリーとスロットが傷んでも、2GBのメモリーで動作するだろう。というわけで、まず、A1で動作していたメモリーをB1に差し込んで検査することにした。

 ところが、POSTの段階でメモリを500MBまで認識したところでプロセスが止まってしまった。慌てて、電源を落としてスロットが傷んでしまったのかと思いながら、見ると、メモリーを両サイドから抑えるピンがはまりきっていない。再度、挿入してテストをすると、POSTをクリアして、"memtest"も正常に開始した。しかも、2回のテストにすぎないが、エラーを吐き出さない。大丈夫かなと首をひねりながら、今度はB1で動作していたメモリーをA1でテストしようとしたときに、問題が生じた。4枚のメモリーはすべて型番は同じだが、メモリーに貼ってある型番のシールにはA1とB1で使用しているメモリーにはBUFFULOのブランドが、A2とB2のメモリーにはCFDのブランドが表示されている。うっかり、B1で検査していたメモリーを外して一旦、静電気を防ぐ包装にしまってからA1で検査するメモリーをもったときに、ふと片手で包装からもう一つのメモリーを取り出して接触部分を見比べようとしたのだが、ちょっと不注意なことにPCの画面に目をとられて、どちらがどちらだったのか区別がつかなくなってしまった。バカな話だ。やむをえないので、一方のメモリーの型番シールに圧力が加わらないように、軽くマークして再度、検査を行った。実は、どちらのメモリー自体からはエラーが検出されなかった。また、A1もPOSTが止まることなく動作した。

 これでは異常がないことになるが、4枚のメモリーをすべて差し込んだ状態で再起動をすると、やはりPOSTのプロセスが止まった。というわけで、再度、A1を集中的に検査すると、POST段階で異常を生じるとメモリーとそうでないメモリーがはっきりと分かれたので、正常に動作するメモリーをB1で再度2回のテストにかけて、エラーがなかった。少し不安があるが、これで、A1はブランクにして、A2、B1、B2にメモリーを装着して3GBで動作させることにした。POSTはすべてクリア。あとは起動するかどうか、ドキドキしたが、正常にOSが起動して漸く安堵した。

 ところが、キーボードは動くがマウスが動かない。これは、USB関連に不具合の多いC521でインストールしたからなのかと思うが、BIOSがOSのインストールに影響するとは思えない。キーボードの操作で再起動をすると、やや時間がたってから、マウスも動くようになったので、ここで安堵した。あとは、グラフィックやサウンド、その他の最低限のドライバをインストールした。USB関連に不安が残るが、USBメモリーや外付けHDDを正常に認識し、取り外しにも異常はない。そこで、プライマリーのHDDのDドライブにインストール用のドライバをコピーして、再度、OSをクリアインストールしても簡単にセットアップできる状態にした。やや神経質だが、USB接続機器が他にも多いので、ここで致命的な問題が生じると、作業に差支えが出る。2、3日はメモリーテストも行う必要も多く、すぐに復帰できる状態ではないので、インターネット接続をせず、ドライバ以外のソフトもインストールせず、様子を見たい。もっとも、このまま使用しても大丈夫なのかもしれないが。

 それにしても、今回の「危機」でPCという道具に振り回されている感じもした。他方で、業務だけでなく、プライベートでもPCなしの生活は難しく、10年前と比較してPCという道具にはるかに依存していることを実感する。正直なところ、不具合が生じてから生活のリズムが崩れたことも大きいが、精神的に不安定になることもあった。時々、道具に振り回されているという不条理に嫌気が差すこともあるが、上手につきあってゆくしかないのだろう。
posted by Hache at 08:00| Comment(5) | TrackBack(0) | 情報通信技術関連
この記事へのコメント
お久しぶりのカワセミです。

memtestはカリカリにチューンするユーザー向けという側面があるので、その手の不良チェックであれば各種テストの中では厳しい#4のランダムパターン書き込みに入ってしばらく経過するくらいで充分かと思います。フルチェックは最後に念のため、という感じでしょうか。まぁ、結構な種類のマザーで4枚挿しは微妙だったりするので2GB×2で使用するのがいい気もします。手動でレイテンシを5-5-5-15あたりに落とすと安定する事例もあります。

余談ですが、メモリはモジュールメーカーの型番が同じでもリビジョンが違うだけで全然違うチップを使っているというようなことが当たり前のようにあります。買う時期が違うと違うものくらいに思っておいた方がいいですね。同じチップメーカーの別の仕様のものが載っていて挙動は全然違ったなんてことまであるので、勘弁してくれと思います。
http://ramlist.i4memory.com/ddr2/

SP3は当て方が難しく、やはり統合インストールがいいでしょう。元ディスクが統合前のオリジナルならあまり問題ないと思うのですが。難しいなら各種ドライバをインストールする前に、本当のOSインストール直後に入れるべきと思います。

ASUSのマザーはトップシェアだけあって無難なものが多いのですが、ものによってはややこの会社独自の挙動をするものがあります。特にHDDやUSBのI/O周りで良く出てきます。最近だとモデルによってはSerial ATAの6番ポートを標準でリムーバブル扱いにしていたりとかBIOSが妙な仕様なものがあります。なもので、私は設定の多くが自分で調整できるDFIあたりを使っています。人に薦めるなら今ならGIGABYTEあたりでしょうか。困ったことにチップセットの世代が変わるたびにお薦めのメーカーも入れ替わるのが昨今の情勢ですが。
Posted by カワセミ at 2009年01月19日 23:23
>カワセミ様

コメントを賜り、恐縮です。memtestは時間がかかるので、アドバイスを頂き、助かりました。OCで性能を引き出すほどの作業はしていないので、メモリーのチェックを行う際には、もっと簡略化します。

メモリーの意外な話も勉強になります。今回の不具合は、おそらく、増設後、念のために既に装着していたメモリーも再度、装着した際に起きた可能性が高いかなと思っております。それにしても、型番が同じでも、チップが異なるというのは意外でした。思っていたより、面倒ですね。2、3ヶ月ぐらい前に増設用メモリーを買おうと思ったのですが、2GBの2枚組へ買い換えるか、1GBの2枚組で増設するのか迷いましたが、カネを惜しまずに、2GB2枚組にした方がよかったかなと思います。浅知恵ですが、使用するスロットが少ない方が、マザーへの負担が少なく、データの転送も速いかなと思ったりします。

自作機ではSP3の適用で不具合が生じることがほとんどないのですが、どうも統合化したDVDをなぜか読み込んでくれないので、再度、作り直してみます。

マザーボードに関しては、今回のメモリー関連以外では、意外と安定しているのですが、細かいところではオンボードのSoundMAXは扱いづらいです。スピーカーを検出すると、キーボードもマウスも反応しなくなって、電源を落とすしかなくなるので、ノイズがひどいときもありますが、PCIでSoundBlasterを使っていました。

SATAポートに妙な設定をするのは驚きですが、よく仕様を確かめて、買い替えの準備をしてみます。今のところ、OCよりも安定してくれる方が優先順位が高いので、P5K-Eあたりで十分なのですが、もう世代交代が進んでしまって、なかなか安定したマザーを見つけるのが大変です。お勧めのGIGABYTEを本線にMSIあたりと比較して検討します。

今後も、ご教示を賜りますよう、お願い申し上げます。
Posted by Hache at 2009年01月20日 01:16
あ、言い忘れましたが、この件も複合要因として絡んでませんかね?私は見事に該当したのでSeagateの対応待ちですが。
http://akiba-pc.watch.impress.co.jp/blog/archives/2009/01/seagatehdd.html

>細かいところではオンボードのSoundMAXは扱いづらいです。

まぁ、褒める人あまりいませんよね。Realtekのほうがマシな感じです。LANも最近の8111C以降は随分マシになったようで、安かろう悪かろうのイメージはかなり減りました。

サウンドと言えば私はUSB音源を一時使っていたのですが、ノイズは少ないものの環境によって挙動が怪しいことがあるのであまり使わなくなりました。Rolandとかの1394音源は使ってみたいのですが微妙に手が出しづらいです。最近のサウンドカードを1枚買ってもいいかもしれませんね。

これも余談ですが、一部のミニコンポ(ONKYOのintecなど)は光デジタル入力があるのでサウンド出力をそちらに入れて使うことがあります。変なPC用スピーカーより割安な場合もあるので穴と思いました。

>お勧めのGIGABYTEを本線に

買い替えというより、1台増やしてみてはどうでしょう:−)
Posted by カワセミ at 2009年01月21日 00:06
何とか苦境を脱出されたようで何よりであります。
当方の自作機は、AthlonXPの1GHzちょいあたりで動いてるような骨董品ですので(HDDも未だPATAだし)。むしろこちらが何だか勉強になったと言いましょうか。当方もいずれMBとHDDごと一挙に換装しようと思ってます。ので、メモリには気をつけたいと思います(笑)
Posted by やすゆき at 2009年01月21日 00:15
思った以上に、OSの再インストールも沼でした。ご助言を頂いたことに、感謝いたします。

>カワセミ様

貴重なご助言、ありがとうございます。不幸中の幸いと申しますか、SeagateのHDDに関連する不具合は生じておりませんでした。ちょっと不思議なトラブルですね。Seagateのサイトで確認しましたが、型番では該当するようですが、8月に買った分では、大丈夫です。ただ、念のため、挙動には要注意ですね。

SoundMAXの音質はともかく、スピーカーを検出した後に、ウィンドウを消すと、キーボード・マウスを一切、受け付けなくなるので、嫌になります。

1台はメーカー製でなにかあったときに備えておきたいのですが。デルのC521はマザーと光学ドライブがガンなので、マイクロATXでマイナーチェンジもありかなと考えております。問題は、OSでクリーンインストールする際のCDキーがわからないので、ちょっと難しいです。

>やすゆき様

ご助言ありがとうございます。「寝言」なのでコメント欄で勉強させていただくという、「ボッタクリブログ」を目指したわけではないのですが、そうなってしまいました。ちなみに職場では6年ぐらい前のPen4の2GHzですが、これが一番安定しています…orz

メモリは、たぶんですが、増設する際に、あっさり填まりすぎて、こんな感じで大丈夫と既に装填していたのを外して再度、填め込んだときになにかやってしまったのかもです。いきなり相性問題が起きていたら、自作から撤退していたかもです。
Posted by Hache at 2009年01月24日 02:09
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。
※ブログオーナーが承認したコメントのみ表示されます。
この記事へのトラックバックURL
http://blog.sakura.ne.jp/tb/25647731
※ブログオーナーが承認したトラックバックのみ表示されます。

この記事へのトラックバック